
aya is a powerful 3D modeling, animation, effects, and rendering
solution that has been used in everything from product design to
feature films. In capable hands, it can produce any sort of image ima-
ginable, from an impressionistic painting to highly realistic anima-
tion and special effects.

Because of its power, Maya has a wealth of features and can seem complex at first
glance. But this shouldn’t overwhelm those new to the package. Getting to know a major
piece of software such as Maya is much like getting to know a large city. First you need
to look at a large map of the city to get a general overview, and then you explore it a
neighborhood at a time. Essentially, that’s how this book works. This first chapter intro-
duces you to a general map of Maya and helps you get used to navigating the software.
Subsequent chapters explore sets of features such as modeling, rendering, and anima-
tion in greater depth. When you take it a step at a time, Maya is easy to learn and use.

Introduction to Maya
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The Maya Interface
Knowledge of the Maya interface is the foundation of everything you will do in Maya, from creating models to tex-
turing, animating, and final rendering. Maya offers a lot of flexibility, and you can customize it in myriad ways.

2 1 . Introduction to Maya

QWERTY tools Used to 
manipulate objects and 
named after their keyboard 
shortcuts: (Q) Select; (W) 
Move; (E) Rotate; (R) Scale; 
(T) Show Manipulators; and 
(Y) Repeat Last Tool.

Viewports Primarily used to 
see your 3D scenes through 
camera or orthographic views. 
Viewports can also contain 
data about the scene, such as 
with the Hypergraph or the 
Multilister.

Layouts Instantly changes 
the configuration of the 
viewports to a number of 
preset layouts.

Time Slider Lets you move 
left and right to scrub 
through the scene.

Range Slider Limits the 
range of the Time Slider. This 
is handy for long scenes, 
when you want to focus on a 
smaller segment of time.

Help line A short description 
of the tools and how to use 
them.

Command line A place to 
type text-based commands to 
Maya, such as a MEL script. 
Custom MEL scripts can help 
automate any number of 
tasks.

Menu sets Lets you switch 
between sets of menus for 
the tasks of animation, 
modeling, dynamics, 
rendering, fur, live, and 
cloth.

Main menu bar Contains 
standard menus (File, Edit, 
Modify, Create, Display, 
Window) followed by menu 
items that are displayed or 
hidden depending on the 
selected menu set.

Status line Contains icons 
used for a number of 
important tasks, such as file 
operations, object and 
component selection, 
snapping, and rendering. 
Each logical group of icons is 
separated by a vertical bar.

Shelf A place to set your 
own custom tools and scripts 
to speed up work flow.

Channel box Contains data 
about the selected objects, 
such as position, rotation, 
and scale.

Playback controls Let you 
play, stop, rewind, and step 
through your animation.

The Status Line
The Status line contains a lot of important icons that assist you with tasks such as manag-
ing files, selecting masks, snapping, and rendering options.

Menu sets Lets you switch 
between sets of menus for 
the tasks of animation, 
modeling, dynamics, 
rendering, fur, live, and 
cloth.

Scene File  Contains icons 
that let you open, save, and 
create new scenes.

Selection masks 
Let you decide 
which components 
are selected when 
you’re in compo-
nent mode.

Snapping 
functions Snap 
the cursor or 
objects to specific 
parts of the scene.

Input/output 
connections 
Manage the way 
objects are 
connected as well 
as construction 
history.

Presets A list of preset 
component types for use 
with selection masks.

Selection modes Let you 
select by hierarchies, 
objects, and components.

Render controls 
Contain icons 
used to render the 
scene and control 
rendering 
options.

Name selection 
Lets you select 
objects by name 
or part of a name.

Channel box Three 
buttons that let you 
show and hide the 
Attribute Editor, 
tool settings, and 
Channel box.
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The QWERTY Tools
These tools are used for selecting and translating and
are accessed primarily through the shortcut keys Q,
W, E, R, T, and Y.

The Maya Interface 3

Select (Q) Selects an object or, by clicking and 
dragging, multiple objects.

Lasso  Selects object(s) by drawing a lasso.

Move (W) Moves the selected object(s).

Rotate (E) Rotates the selected object(s).

Scale (R) Scales the selected object(s).

Soft Modify Allows modification of the object with
falloff.

Show Manipulator (T) Shows the manipulator, 
allowing you to adjust construction history.

Last (Y) Selects the last tool used.

Layouts
The Layouts Tool Box quickly changes the arrange-
ment and layout of the viewports. The viewport
arrangement you choose depends on the task at hand.
If you are texturing and lighting a scene, you’ll want
the Hypershade available. An animator will need easy
access to the Graph Editor. Clicking any of the preset
buttons instantly changes the views as follows:

Single perspective 

Four perspectives

Perspective and Outliner

Perspective and Graph Editor

Hypershade and Perspective

Perspective, Graph Editor, and Hypergraph

Mode select: Each button reveals a rollout allowing 
you to change the mode of the corresponding 
view.

Floating Menus
In Maya, you can tear off and “float” drop-down menus when you need repeated
access to the menu. Simply left-click the double bar at the top of the drop-down. 

Left-click here to float the 
window.
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The Hotbox
Another way to easily access menus is by using the hotbox, which appears when you press
the spacebar. The hotbox places all the menu commands at your cursor. You can customize
the hotbox to include all the available tools or only those currently needed.

4 1 . Introduction to Maya

Recent Commands A list of 
the last tools used; handy 
when performing the same 
operations on different 
obejcts.

Common menus The 
standard menus from the 
menu bar.

Panel menus Menus 
associated with the active 
panel.

Hotbox controls Lets you 
show and hide menus and 
menu sets as well as control 
hotbox display options, such 
as transparency.

Menu sets Menus that are 
contained within the menu 
sets and can be turned 
on/off using the hotbox 
controls.

View select Clicking in the 
center box lets you change 
the view in the current 
viewport.

Marking Menus
Marking menus let you quickly access functions wherever the
cursor is located. Once you memorize a marking menu, you can
quickly select options with a simple keystroke and mouse ges-
ture. Maya has a number of preset marking menus. You can cus-
tomize the interface to your own needs using the Hotkey Edi-
tor, which lets you assign a marking menu to a particular key.

Here are a few standard marking menus:

Holding down the W key while pressing
the left mouse button opens a marking
menu that gives you options for mov-
ing objects.

Pressing the H key selects
the menu set.

Pressing the E key displays the options for rotat-
ing objects.

You can configure and customize hot keys and
marking menus using the Hotkey Editor (choose
Window → Settings/Preferences → Hotkey).
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The Channel Box
Clicking this button , which is on the far right of the Status line, displays the Channel
box. The Channel box sits along the right side of the interface and lets you quickly edit an
object’s main attributes. Translate, Rotate, and Scale are the most common attributes, but
the Channel box provides control over many parameters of an object. It can also act as an
animation interface, in which you can key parameters simply by right-clicking. You can
also lock attributes so they can’t be changed. This is helpful when the object needs to
remain stationary, for example.

The Maya Interface 5

Mode Switches between Channel box, 
Layer Editor, or both.

Channels Drop-down menu that lets you 
key attributes, copy and paste 
attributes, and lock or unlock attrbutes. 
This menu is also available by right-
clicking over the Channel box.

Object If multiple objects are selected, 
lets you show the individual channels of 
any one object.

Attributes Attributes for the object, 
such as Translate, Rotate, and Scale, 
along with others. You can change these 
by typing new values or by highlighting 
the attribute(s) and then dragging the 
mouse while holding down the middle 
mouse button.

Locked attributes To lock or unlock an attribute, 
highlight the attribute, and then right-click to 
display the Channels menu, which has the lock and 
unlock selection command.

Inputs Modifiers that change the object.

Input attributes Modifiable attributes related to 
the selected input.

Layer Manager Controls layering.
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The Attribute Editor
The Attribute Editor is an important window in Maya and takes the concept of the Channel
box a step further. Every object in Maya is defined by a collection of attributes, such as its
position, color, shading, shape, and so on. The Attribute Editor is the interface where you
can control and modify these attributes in detail.

The Attribute Editor has a series of tabs representing the nodes connected to the main
object. Each node affects the object in a specific way, from altering the shape of the object
to determining its shading.

Clicking this button , which is on the far right of the Status line, places the Attribute
Editor on the far right of the screen. You can also open the Attribute Editor by choosing
Window → Attribute Editor from the menu bar. Pressing Ctrl+A also displays the Attribute
Editor for the selected object.

6 1 . Introduction to Maya

Main menu Menus to control the 
Attribute Editor.

Nodes Tabs that contain attributes for 
each node connected to the object. 
These can be nodes that contain 
attributes used to modify the shape of 
the object, apply shaders, and so on.

Transform Attributes Translate, Rotate, 
and Scale attributes for the master 
node.

Pivots Lets you display a separate 
rotate and scale pivot.

Local/World Space Lets you adjust the 
rotate and scale pivots to local and 
world space.

Limit Information A series of rollouts 
that let you limit the object’s transla-
tion, rotation, and scale.

Display Attributes that control how an 
object is displayed.

Display Handle When checked, displays 
a handle with which to select the 
object.

Rollouts Contains more parameters.

Extra Attributes Any node can contain 
custom attributes defined through the 
Attributes drop-down at the top of the 
Attribute Editor.

List Lets you load attributes 
manually or automatically 
when the object is selected.

Selected If multiple items 
are selected, lets you display 
the attributes of any one 
object.

Focus Displays all nodes that 
have been selected in the 
scene while the Attribute 
Editor is open. The most 
recently selected node is at 
the top of the list.

Attributes Lets you add, 
edit, and delete extra 
attributes for an object or a 
node. These appear in the 
Extra Attributes section. You 
can also add, edit, and delete 
attributes using the Modify 
menu.

Notes Each node can contain 
notes to aid in documentation.

SBX4404c01_p3.0.qxd  2/25/05  12:51 PM  Page 6



Viewports
Viewports are where most of the work in Maya happens. Viewports can hold views of your
scene as well as other types of windows that display information about your scene. The two
types of views within Maya are perspective and orthographic. You select and change views
using the Panels drop-down at the top of every viewport.

Viewports 7

Orthographic views, such as top, front, and side views, only allow dolly and pan.

Perspective views let the camera rotate in 3D space as well.

Use the Panels drop-down to change views.
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Shading
Each view can have its own level of shading for view-
ing objects at different levels of realism. If you are
creating models, you might want to view just the
wireframe, but others might want to view the fully
shaded and textured objects. The more realistic the
shading, however, the slower the interaction; so com-
plex scenes can bog down the system. One handy
option is shading only the selected items. Not only
does this speed interaction in complex scenes, it
helps the selected items stand out.

8 1 . Introduction to Maya

Wireframe shows a simple
outline of the object.

Flat Shading fills in the
spaces between the wires.

Smooth Shading displays a
smooth object.

Hardware Texturing displays
textures. The quality of the
textures depends on the
graphics card.

High Quality Rendering
shows advanced features
such as bumps and 
transparency.

The Shading drop-down on
the top of the viewport con-
trols the shading level.

Tumble: Alt or Option
plus the left mouse
button rotates the
camera around a per-
spective view.

Track: Alt or Option
plus the middle mouse
button moves the
camera left/right and
up/down.

Navigation
To navigate within a view, hold down the
Alt or Option key while clicking a mouse
button.

Additionally, pressing F frames the
current selection, and pressing A frames
everything in the current scene.

Dolly: Alt or Option
plus the right mouse
button moves the
camera toward and
away from the subject.
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Objects
Maya supports a variety of object types, including surfaces,
curves, joints, and handles, among others. To select individual
objects or multiple objects, set the selection mode to Object
and select with the mouse. You can also select objects in the
Hypergraph or Outliner.

Using the selection masks on the Status line, you can refine
object selection. By toggling the selection masks, you can
select only the types of objects you want.

Selecting Objects
Objects in Maya can be NURBS (Non-Uniform Rational B-Spline) surfaces,
polygonal surfaces, curves, cameras, lights, cameras, and joints, among
others. Maya has three levels of selection: objects themselves, groups of
objects (hierarchies), and parts of objects (components). Maya also has a
sophisticated masking system that lets you select only the objects or
components you want.

Hierarchies
Hierarchies are groups of objects. To create a
hierarchy, select multiple objects, and then choose
Edit → Group. You can select a hierarchy by clicking
the Hierarchy icon on the Status line, from within
the Hypergraph (choose Window → Hypergraph), 
and from within the Outliner (choose Window →
Outliner).

Selecting Objects 9

Hierarchy        Objects

Components

A group of icons on the Status line
determines the selection mode.

This object is actually made
of several obects…

...which are tied together in
a hierarchy.

You can manage and select
hierarchies of objects in the
Hypergraph … …as well as in the Outliner.

Handles Used to aid in 
the selection of objects.

Joints Used as 
bones to deform 
characters.

Curves Used to help 
build surfaces.

Surfaces NURBS, 
polygonal surfaces, 
subdivision 
surfaces, or planes.

Deformations Clusters, 
lattices, and other tools 
used to deform objects.

Dynamics Particles 
systems, and soft bodies 
used for special effects.

Rendering Lights, 
cameras, textures, 
and other objects 
related to 
rendering.

You use hierarchies to logically group objects for
scene management, as well as to help create complex
animations. A good example is the lamp. The base of
the lamp is the “root” node of the hierarchy; moving
this moves the child nodes, such as the arm and the
head of the lamp. Adjusting a child node, however,
such as the arm of the lamp, affects only those nodes
lower in the hierarchy, such as the head of the lamp.
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Components
You use components to modify and change the shape of an object, such
as a curve or a surface. Each type of object has different types of compo-
nents. A NURBS surface has components such as hulls and control ver-
tices (CVs), and a polygonal surface has vertices, edges, and faces. Using
the selection masks helps you to limit the types of components selected:

10 1 . Introduction to Maya

NURBS isoparms NURBS patches NURBS hulls

NURBS CVs

Polygonal vertices Polygonal edges Polygonal faces

Quick Select
Quick Select, located on the Status line, lets you enter the
name of an object to select it. This is handy when an object is
in a complex scene and hard to find. Using an asterisk (*)
selects all objects containing the characters, making it easy to
select all similar items with a few keystrokes. For example,
when selecting parts of a character, typing Hand* might select
everything related to that character’s hand. Devising and
sticking to a naming scheme can help tremendously when
working on large projects.

SBX4404c01_p3.0.qxd  2/25/05  12:51 PM  Page 10



The Outliner
Another way to select objects and manage hierarchies is with the Outliner. The Outliner
presents all the items in the scene as a hierarchical list. You can quickly scroll through this
list to select scenes, and objects or hierarchies of objects.

To open the Outliner, choose Window → Outliner. You can also configure the Outliner to
reside in a viewport using the viewport’s drop-down menus.

To select an item in the Outliner, left-click it. To select multiple items, left-click and
drag them. Holding down the Shift key lets you select objects in groups by clicking the
first and last item of the group. Holding down the Ctrl key lets you add or subtract items
from the selection individually. You can easily rearrange hierarchies by middle-clicking the
item and dragging it.

Selecting Objects 11

Display Drop-down menu to control how much information is 
displayed.

Show Drop-down menu to show and hide types of objects.

Text filter Typing a name or a global (such as bolt*) displays 
only those objects that match the criteria.

Root node Highlighted in green, this is the root node of the 
selected item(s).

Selected item Selected items are highlighted in gray.

Close hierarchy Left-clicking the minus sign (–) sign closes 
the hierarchy.

Open hierarchy Left-clicking the plus sign (+) sign opens the 
hierarchy.

Second view Moving the bar along the bottom of the screen 
gives you a second view of the hierarchy; useful when 
managing complex scenes.
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Transforming Objects
Transformations change an object’s translation, rotation, and
scale. These changes are stored in the object’s transform node.
You access the Transformation tools using the hot keys: W
(Move); E (Rotate); R (Scale). You can also select these tools
from the Tool Box on the left side of the interface.

Each transformation tool has its own manipulator, and each
manipulator is color coded. Red is the X axis, green is Y, and
blue is Z. Left-clicking and dragging in the center of the
manipulator moves the object on all available axes; clicking and
dragging an individual manipulator transforms the object only
on the selected axis.

Coordinate Systems
Transformations can take place along a number of dif-
ferent XYZ coordinate systems. These primarily affect
how an object is moved. You can change coordinate sys-
tems using the options panel for each tool.

12 1 . Introduction to Maya

Move manipulator Rotate manipulator Scale manipulator

Choose Modify → Freeze Trans-
formations to set all your objects’ current
transformations at their zero positions.
Choose Modify → Reset Transformations to
set the transformations on selected objects
back to zero, placing the objects at their ori-
gin. This resets any transformations since
the objects were created or the last time you
used Freeze Transfomations.

T I P

To access the options for 
any command, click the
small box to the right of the
command’s name in the
menu.
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The Move Tool
Move tool options (choose Modify → Transformation Tools → Move Tool) select the coordi-
nate system for the Move tool.

Transforming Objects 13

World space is the default 
coordinate system and has 
its axis aligned with those of 
the scene’s X, Y, and Z axes.

Object space is aligned with 
the selected object. If the 
object is rotated, the 
orientation of X, Y, and Z 
rotate as well.

Local space is aligned with 
the selected object’s parent.

Normal space is aligned with 
the individual normals when 
in component mode. Instead 
of X, Y, and Z, Maya uses U, V, 
and N for the coordinates.

The Move tool options panel

The Rotate Tool
Rotate tool options (choose Modify → Transformation
Tools → Rotate Tool) select the coordinate system for
the Rotate tool.

Pivots
The pivot is the center of each object’s coordinate
system. This is particularly important when using the
Rotate tool, because the object rotates around the
pivot.

To adjust the placement of the pivot, press Insert
while in move mode. Once the pivot is in the proper
location, pressing Insert locks the pivot in place.

Another way to automatically adjust pivots is to
choose Modify → Center Pivot. This moves the pivot
to the geometric center of the object.

When the pivot is placed outside the
wheel, the wheel rotates around the
wrong center.

When the pivot is
moved to the cen-
ter of the wheel,
the wheel rotates
properly.
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Connecting Objects
In Maya, every object is a collection of intercon-
nected nodes. These nodes modify such items as the
object’s shape, shading, and construction history. To
control the attributes of these connections, you can

14 1 . Introduction to Maya

Edit Commands that let you 
collapse and expand 
hierarchies.

View Commands to frame 
selected objects as well as 
hierarchies or branches of 
hierarchies. These functions 
are duplicated with the 
Frame All, Frame Selection, 
Frame Hierarchy, and Frame 
Branch icons.

Bookmarks Commands to 
create bookmarks to easily 
index parts of a complex 
scene or hierarchy. These 
functions are duplicated with 
the Add Bookmark and Edit 
Bookmark icons.

Nodes Object nodes.

Rendering Commands used 
to manage and display nodes 
related to rendering.

Options Manage the 
Hypergraph.

Show Options to show and 
hide objects by type.

Graph Selects between 
displaying hierarchies or 
connections. These functions 
are duplicated with the 
Scene Hierarchy and 
Input/Output connections 
icons.

Help Help menu.

Toggle freeform Toggles 
between freeform and 
automatic layout of nodes.

Bookmark icons Create and 
manage bookmarks.

Display Connections icons 
Displays the input/output 
connections for the selected 
object.

Display Hierarchy icons 
Displays the scene hierarchy.

View icons Frame All, Frame 
Selection, Frame Hierarchy, 
and Frame Branch.

Text filter Typing a name or 
a global (such as bolt*) 
displays only those objects 
that match the criteria.

Connections Connections 
between nodes.

Right-clicking along the right edge of a
node displays the possible connections
for that node.

To open the Hypergraph, choose Window → Hyper-
graph. You can configure the Hypergraph to reside in
a viewport using the viewport’s drop-down menus.
You navigate in the Hypergraph the same as you
navigate in any view:

• Alt or Option plus middle mouse button for pan
• Alt or Option plus right mouse button for zoom

The Hypergraph
The Hypergraph shows the contents of a scene as a
network of boxes connected via lines. In this way, it
functions much like a graphical version of the Out-
liner. The Hypergraph goes much deeper, however.
Not only does it show the hierarchical connections
between objects, but it also shows the way nodes and
their attributes are connected.

use the Attribute Editor, but the Hypergraph and the
Connection Editor give you control over the connec-
tions and dependencies themselves.

Right-clicking the body
of a node displays the
main Hypergraph menu.
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Managing Hierarchies 
in Hypergraph
In hierarchy mode (choose Graph → Scene Hierarchy), the
Hypergraph shows the objects in the scene as a tree. Each
object is represented as a box, with the hierarchy represented
as lines. Selecting the box in the Hypergraph also selects the
corresponding item in the scene.

To modify the hierarchy in the Hypergraph, select the
nodes, middle-click, and drag the line to the parent. To com-
pletely unparent a node, drag the line to an empty spot on the
Hypergraph.

Managing Connections 
in Hypergraph
The Dependency Graph (choose Graph → Input and Output Connections)
is the graphical equivalent of the Attribute Editor. It lets you view the
nodes that comprise objects and visualize how those nodes are con-
nected. The Dependency Graph displays the connections for selected
objects only.

Connections are created automatically as the scene is constructed.
You can also make and break the connections manually to create all
sorts of relationships between objects. The motion of an object along
one axis can be used to drive the scale of another object, for example.

To delete a connection, click the line representing the connection and
press Delete. To create a connection, move the mouse over the right end
of the originating node until the cursor changes, middle mouse click,
drag to the upstream node, and release. This opens a menu, which allows
you to select the parameters to be connected in the Connection Editor.

Connecting Objects 15

When you select freeform mode (choose Options →
Layout → Freeform), these boxes can be arranged
in any order. This is useful for creating graphic
representations of the objects in the scene, such
as having the boxes represent the joints of a
character.

Curves

Loft

This fender is composed of four curves,
which are lofted together (choose Sur-
faces → Loft) to create the surface.

Curves Loft

The Dependency Graph shows how the
four curve nodes are connected to the
loft node, which creates the surface.

Deleted

Deleting the connection from one of
the curves to the loft node….

...also removes it from the resulting
surface.
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The Connection Editor
You use the Connection Editor (choose Window → General Editors → Connection Editor) to
connect attributes. It is divided into two vertical panes. Each pane contains a list of attrib-
utes from the selected objects, which can then be selected and connected using the “from 
-> to” button.

To load an object’s attributes into the Connection Editor, select the object and click
either Reload Left or Reload Right. To connect attributes, left-click to highlight them on
each side of the window.

16 1 . Introduction to Maya

Attributes Available 
attributes are shown in 
black, unavailable ones in 
gray.

Selected Attributes The 
selected attributes are 
connected and highlighted in 
blue.

Loads the selected object’s attributes in 
the left pane.

Toggles the direction of the 
connection.

Loads the selected object’s attributes in 
the right pane.
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Managing Files
Projects in Maya can encompass many types of files: 3D geometry, texture maps, rendered
images. Organizing these files can be a challenge, but Maya provides a standard folder
structure for projects that keeps everything in the proper place. Maya is not limited to this
structure, however, and you can create and store your assets in any manner you want. Pro-
ductions that involve multiple artists can store all the files on a central server, for example.
Assets that are used in multiple projects can be stored in their own folder structure.

Maya Folders
Each user on the system gets a Maya folder
in their home folder. This allows each user
to maintain their own preferences, such as
custom layouts, as well as have a place for
their own projects.

Managing Files 17

Each version of Maya 
maintains its own 
folder for installing 
custom preferences 
and scripts.

A folder hierarchy 
that contains Maya 
projects.

This is where most 
custom MEL scripts 
should be saved.

The Maya folder

Each project has its own folder and 
hierarchy. Maya creates the default 
project, which you can copy to create 
new project hierarchies.

Animation clips used in the Trax 
nonlinear animation editor.

Maya stores rendered images here.

Files related to the creation of particle 
systems.

Temporary rendered images for the IPR 
renderer, depth maps, and shaders are 
stored here.

Scene files ready to be rendered should 
be stored here.

Save your scene files in this folder.

Audio files for use in animation.

A folder that holds texture and image 
maps.

Exported textures are stored here.

The Maya projects folder
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Setting and Editing Projects
To set the current project, choose File → Project → Set to open a file
browser in which you can select the new project folder.

To edit the current project, choose File → Project → Edit Current to
open an instance of the project window, where you can change the fold-
ers as needed.

Creating Projects
To create a new project, choose File → Project → New to open the New Project dialog box,
in which you can define the folder locations for the project. It’s always best to click the Use
Defaults button at the bottom of the window, as it fills in most of the values automatically.

18 1 . Introduction to Maya

Name of the project.

Location of the project hierarchy.

Where the Maya scenes are stored.

Data for other components of the scene, 
such as textures, particles, lights, and 
so on. You can change individual entries 
to point to other places on the network, 
such as a shared texture library, for 
example.

Folders used when exporting to 
nonnative file formats.

Automatically fills in the entries with 
the most commonly used values.

File browser used to select a new 
project
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